Poglavje 16. Meniji

Kazalo

1. Predstavitev menijev
1.1. The Image Menu Bar
1.2. Kontekstni meniji
1.3. Tear-off menus
1.4. Tab menus
2. Meni “Datoteka”
2.1. Pregled
2.2. Nov
2.3. Ustvari
2.4. Odpri
2.5. Odpri kot plasti
2.6. Odpri naslov
2.7. Odpri nedavne
2.8. Shrani
2.9. Shrani kot
2.10. Shrani kopijo
2.11. Povrni
2.12. Export
2.13. Export As...
2.14. Create Template
2.15. Natisni
2.16. Zapri
2.17. Zapri vse
2.18. Izhod
3. Meni “Uredi”
3.1. “Edit” Menu Entries
3.2. Razveljavi
3.3. Ponovi
3.4. Pojemanje
3.5. Zgodovina razveljavitev
3.6. Izreži
3.7. Kopiraj
3.8. Kopiraj vidno
3.9. Prilepi
3.10. Prilepi v
3.11. Prilepi kot
3.12. Medpomnilnik
3.13. Počisti
3.14. Napolni z barvo ozadja
3.15. Napolni z barvo ozadja
3.16. Napolni z vzorcem
3.17. Vleci poteze po izboru
3.18. Vleci poteze po poti
3.19. The “Preferences” Command
3.20. Keyboard Shortcuts
3.21. Gradniki
3.22. Enote
4. The “Select” Menu
4.1. Introduction to the “Select” Menu
4.2. Izberi vse
4.3. Brez
4.4. Preobrni
4.5. Plavajoče
4.6. Po barvi
4.7. Iz poti
4.8. Urejevalnik izbora
4.9. Operjeno
4.10. Izostri
4.11. Skrči
4.12. Povečaj
4.13. Rob
4.14. Popači
4.15. Zaobljen pravokotnik
4.16. Vključi/izključi hitro masko
4.17. Shrani v kanal
4.18. V pot
5. Meni “Pogled”
5.1. Introduction to the “View” Menu
5.2. Nov pogled
5.3. Točka za točko
5.4. Zoom
5.5. Skrči z ovijanjem
5.6. Celozaslonsko
5.7. Okno krmarja
5.8. Pokaži filtre
5.9. Pokaži izbor
5.10. Pokaži meje plasti
5.11. Pokaži vodila
5.12. Pokaži mrežo
5.13. Pokaži vzorčne točke
5.14. Pripni na vodila
5.15. Pripni na mrežo
5.16. Pripni na rob platna
5.17. Pripni na aktivno pot
5.18. Padding Color
5.19. Pokaži menijsko vrstico
5.20. Pokaži ravnila
5.21. Pokaži drsnika
5.22. Pokaži vrstico stanja
6. Meni “Slika”
6.1. Pregled
6.2. Podvoji
6.3. Način
6.4. Način RGB
6.5. Grayscale mode
6.6. Indexed mode
6.7. Preoblikuj
6.8. Flip Horizontally; Flip Vertically
6.9. Rotation
6.10. Giljotina
6.11. Velikost platna
6.12. Prilagodi platno plastem
6.13. Prilagodi platno izboru
6.14. Velikost tiskanja
6.15. Spremeni merilo slike
6.16. Obreži v izbor
6.17. Samodejno obreži sliko
6.18. Obreži pristrano
6.19. Spoji vidne plasti
6.20. Splošči sliko
6.21. Poravnaj vidne plasti
6.22. Vodila
6.23. Novo vodilo
6.24. Novo vodilo (v odstotkih)
6.25. Nova vodila iz izbora
6.26. Odstrani vsa vodila
6.27. Prilagodi mrežo
6.28. Lastnosti slike
7. Meni “Plast”
7.1. Introduction to the “Layer” Menu
7.2. Nova plast
7.3. New Layer Group
7.4. Novo iz vidnega
7.5. Podvoji plast
7.6. Zasidraj plast
7.7. Merge Down
7.8. Izbriši plast
7.9. The Text Commands of the Layer Menu
7.10. Zavrži besedilne podatke
7.11. Podmeni “Sklad”
7.12. Izberi prejšnjo plast
7.13. Izberi naslednjo plast
7.14. Izberi vrhnjo plast
7.15. Izberi plast na dnu
7.16. Dvigni plast
7.17. Spusti plast
7.18. Plast na vrh
7.19. Plast na dno
7.20. The “Reverse Layer Order” command
7.21. Podmeni “Maska”
7.22. Dodaj masko plasti
7.23. Uporabi masko plasti
7.24. Izbriši masko plasti
7.25. Pokaži masko plasti
7.26. Uredi masko plasti
7.27. Onemogoči masko plasti
7.28. Maska v izbor
7.29. Dodaj masko plasti izboru
7.30. Odštej masko plasti od izbora
7.31. Intersect Layer Mask with Selection
7.32. The “Transparency” Submenu of the “Layer” menu
7.33. Dodaj kanal alfa
7.34. Odstrani kanal alfa
7.35. Barva v alfo
7.36. Delno splošči
7.37. Prag alfa
7.38. Alfa v izbor
7.39. Add Alpha channel to Selection
7.40. Odštej od izbora
7.41. Intersect Alpha channel with Selection
7.42. The “Transform” Submenu
7.43. Prezrcali vodoravno
7.44. Prezrcali navpično
7.45. Zasukaj za 90° v SUK
7.46. Zasukaj za 90° v NSUK
7.47. Zasukaj za 180°
7.48. Poljubni zasuk
7.49. Offset
7.50. Layer Boundary Size
7.51. Plast na velikost slike
7.52. Spremeni merilo plasti
7.53. Obreži v izbor
7.54. Samodejno obreži plast
8. Meni “Barve”
8.1. Introduction to the “Colors” Menu
8.2. Colors Tools
8.3. Preobrni
8.4. Preobrni vrednosti
8.5. Uporabi GEGL
8.6. The “Auto” Submenu
8.7. Izenači
8.8. Nastavitev beline
8.9. Color Enhance
8.10. Normaliziraj
8.11. Raztegni kontrast
8.12. Razširi HSV
8.13. The “Components” Submenu
8.14. Mešalec kanalov
8.15. Skladaj
8.16. Razstavi
8.17. Ponovno sestavi
8.18. The “Map” Submenu
8.19. Prerazporedi katalog barv
8.20. Nastavi katalog barv
8.21. Poslikaj napis
8.22. Izmenjava barv
8.23. Zemljevid preliva ...
8.24. Zemljevid palete
8.25. Zasukaj barve
8.26. Prebarvaj z vzorcem
8.27. The “Info” Submenu
8.28. Histogram
8.29. Povprečje robu
8.30. Analiza barvne kocke
8.31. Zgladi paleto
8.32. The Color Filters
8.33. Naredi pisano
8.34. Barva v alfo
8.35. Filter Pack
8.36. Vroče
8.37. Največji RGB
8.38. Retinex
9. Meni “Orodja”
9.1. Introduction to the “Tools” Menu
10. Meni “Filtri”
10.1. Uvod v meni “Filtri”
10.2. Ponovi zadnjega
10.3. Ponovno pokaži zadnjega
10.4. Ponastavi vse filtre
10.5. Podmeni “Python-Fu”
10.6. Podmeni “Skript-Fu”
11. “Windows” Menu
12. Meni “Pomoč”
12.1. Introduction to the “Help” Menu
12.2. Pomoč
12.3. Kontekstna pomoč
12.4. Nasvet dneva
12.5. O programu
12.6. Brskalnik vstavkov
12.7. Brskalnik procedur
12.8. GIMP na spletu

1. Predstavitev menijev

There are many places in GIMP where you can find menus. The aim of this chapter is to explain all the commands that are accessible from the image menu bar and the image menu you can get by right clicking in the canvas. All the context menus and the menu entries for the other dialogs are described elsewhere in the chapters that describe the dialogs themselves.

1.1. The Image Menu Bar

This menu bar may contain other entries if you have added script-fus, python-fus or videos to your GIMP.

1.2. Kontekstni meniji

If you right-click on certain parts of the GIMP interface, a “context menu” opens, which leads to a variety of functions. Some places where you can access context menus are:

  • Clicking on an image window displays the Image menu. This is useful when you are working in full-screen mode, without a menubar.

  • Clicking on a layer in the Layers Dialog or on a channel in the Channels Dialog displays functions for the selected layer or channel.

  • Right-clicking on the image menubar has the same effect as left-clicking.

  • Right-clicking on the title bar displays functions which do not belong to GIMP, but to the window manager program on your computer.

1.3. Tear-off menus

There is an interesting property associated with some of the menus in GIMP. These are any of the menus from the Image context menu you get by right-clicking on the canvas and any of its submenus. (You can tell that a menu item leads to a submenu because there is an icon next to it.) When you bring up any of these menus, there is a dotted line at the top of it (tear-off line). By clicking on this dotted line, you detach the menu under it and it becomes a separate window.

Slika 16.1. The “windows” submenu and its tear-off submenu

The “windows” submenu and its tear-off submenu
The “windows” submenu and its tear-off submenu

Tear-off menus are actually independent. They are always visible, their functions always apply to the current image, and they persist when all of the images are closed. You can close a tear-off submenu by clicking on the dotted line again or closing the window from the window manager on your computer (often by clicking on an X icon in the upper right corner of the window).

These tear-off submenus are also created in single-window mode, but are of less interest since they are masked by the window as soon as you click on it.

1.4. Tab menus

The following type of menus is not related to the image menu bar, but for the sake of completeness:

Every dockable dialog contains a Tab Menu button, as highlighted below. Pressing this Tab Menu button opens a special menu of tab-related operations, with an entry at the top that opens into the dialog's context menu.

Slika 16.2. A dockable dialog.

A dockable dialog.

A dialog window with the Tab menu button highlighted.

A dockable dialog.

The Tab menu.


See Razdelek 2.3.2, “Tab Menu” to learn more about Tab menus.